Bulk Changes > Deal Flow

Incident Report for Investment Dominator

Identified

We identified the issue and we are actively working on a fix for bulk updates to Deal Flows
Posted Jun 19, 2026 - 20:18 UTC

Investigating

We are currently investigating an error when bulk updating Deal Flows.
Posted Jun 19, 2026 - 20:17 UTC
This incident affects: Admin Console (Actions).